Authorisation issues

Incident Report for Optomany

Resolved

This incident has been resolved.
Posted Jun 23, 2026 - 20:34 UTC

Investigating

We are aware of potential issues with authorisations and are actively investigating.
Posted Jun 23, 2026 - 19:51 UTC
This incident affected: Acquirer Status (FIS (WorldPay)).