Suspected Issues With Global Payments Connections
Incident Report for Optomany
Resolved
This incident has been resolved.
Posted Dec 02, 2023 - 09:34 UTC
Investigating
We are currently investigating this issue.
Posted Dec 02, 2023 - 08:19 UTC
This incident affected: Acquirer Status (Global Payments).