Suspected Issues With Authorisations (Lloyds Cardnet / AIB / FDMS)
Incident Report for Optomany
Resolved
This incident has been resolved.
Posted Nov 16, 2023 - 07:35 UTC
Investigating
We are currently investigating this issue.
Posted Nov 16, 2023 - 07:21 UTC
This incident affected: Acquirer Status (AIBMS, FDMS, Lloyds Cardnet).